新規投稿
フォローする

kintoneルックアップのバグ?

状況も条件も分からないのですが、まれにルックアップの「ほかのフィールドのコピー」が入らない状態で保存されていることがあります。

例)
アプリA:コード(ルックアップ)名前
アプリB:コード 名前
アプリAで「コード」に入力し取得すると、アプリBの「名前」が、アプリAの「名前」にコピーされる

  1. アプリAに保存したレコードで、「コード」はルックアップ状態(青文字になっており、クリックするとアプリBのレコードにリンクされる)なのに、アプリAの「名前」は空欄になっている

  2. 1のようになったレコードで、
    ・編集モードにし、何もせずに保存すると、保存できる
    ・「コード」で取得しなおすと、「名前」がコピーされ、保存できる
    ・「コード」を一度クリアし、再度「コード」に入力して、取得を押さずに保存しようとすると、エラーになり保存できない

  3. 保存時には「名前」が入っていたのか、保存の時点で「名前」が抜けているのかは、不明

同じアカウント、同じ環境(PC/ブラウザ)で同じ作業を行なっても、この現象が起こるときと起こらないときがあります。

フォーラムの過去記事で同じような相談を見つけましたが、こちらは存在しないレコードをルックアップしており、今回の状況では間違いなく存在するレコードをルックアップしています。

ルックアップフィールドのエラーを無視してレコード保存される

詳しい状況が分からない状態でご相談するのは心苦しいですが、何か原因となるもの、また確認すべきポイントなどありましたら、ご指摘いただけますと大変助かります。

また、システム上の不具合であるならば、一刻も早い解消を希望します。
よろしくお願いいたします。

1

3件のコメント

Avatar
サクラエビ

TAKAさん

こんにちは。

私は同じ事象に遭遇したことがないため、環境依存のような気がしていますが、

内容を読む限り、レコードの保存時に必ず発生するものではなく、事象が発生したレコードは

編集画面からの再取得を行った場合、問題なく取得が可能であると思ってよいのでしょうか?

 

ちなみに、現象が発生するアプリにおいて、何かカスタマイズは入れられていますか?

入れているのであれば、それを外した場合どうなるかで、切り分けもできそうな気がします。

0
Avatar
TAKA

サクラエビさん
コメントありがとうございます。

ご指摘いただきました件、下記の通りでございます。

  • 環境依存
    私も当初、それを疑っておりましたが、同じPC・ブラウザ、同じアカウントで発生する/しないがあるため、原因が分からない状況です。

  • 再取得を行なった場合
    問題なく取得できます。現象が起こっているレコードもAPI等によるものではなく手作業で登録しています。

  • カスタマイズ
    入れております。しかし、該当のルックアップはカスタマイズとは関連が無い部分であること、また前述しました通り、必ず起こる現象ではないため、カスタマイズの入り/切りによる検証がしにくい状況でございます。

上記の通りですが、ご指摘いただいた中では、とりあえずカスタマイズを見直すことを先行してみます。
アドバイスありがとうございました。
解決しましたらお知らせ申し上げます。

0
Avatar
サクラエビ

TAKAさん

10回に1回くらいの頻度で起きる状況であれば、カスタマイズを外すもしくは、ルックアップ元を同じにした

簡易アプリを作って、再現確認などもできる気はしますが、コメントを見る限りでは、

そこまでの頻度でもなさそうですし、やはり難儀な状態ですね。

 

もう1点気になったのは、事象が発生するルックアップの値は同じものなのでしょうか?

ここも規則性はない状況でしょうか?

サクラエビにより編集されました
0
ログインしてコメントを残してください。