新規投稿
フォローする

kintone POST ボックス とPepperの連携について

kintone POST ボックス とPepperの連携についての記事を拝見し、実際にトライしてみました。
https://cybozudev.zendesk.com/hc/ja/articles/204740830

が、環境設定後、Choregrapheで再生ボタンを押し、ダイアログボックスで「はい」または「いいえ」を入力してもkintoneにデータがアップロード出来ませんでした。

上記のサンプルにトライされて成功された方はいらっしゃいますか?
記事に記載されていること以外で、コツなどがあればお教え頂けますでしょうか。

私が開発した環境は下記になります。
■windows 7 home Premium
■Choregraphe 2.1.3
■kintone 30日体験版

0

4件のコメント

Avatar
Sada Nishio

qazwsxさん

実際に発生しているエラーを記載いただければ何かわかるかもしれませんがどのようなエラーが発生しているでしょうか?

0
Avatar
qazwsx

Sada Nishio さん
返信いただきありがとうございます。
ログビューアを確認したところ、下記のエラーが発生していました。Speech Recoのあたりで発生しているようです。
ただ、そのあと「はい」または「いいえ」を入力すると最後まで処理されています。

[ERROR] behavior.box :init:10 BehaviorlastUploadedChoregrapheBehaviorbehavior_11890411040rootSpeechReco_5: ALProxy::ALProxy
Can't find service: ALSpeechRecognition
[WARN ] behavior.box :onLoad:15 _Behavior
lastUploadedChoregrapheBehaviorbehavior_11890411040rootSetLanguage_6: ALSpeechRecognition is not available, language setting cannot be applied to recognition
[ERROR] behavior.box :
init:10 _BehaviorlastUploadedChoregrapheBehaviorbehavior_11890411040rootSpeechReco_5: ALProxy::ALProxy
Can't find service: ALSpeechRecognition
[WARN ] behavior.box :onLoad:15 _Behavior
lastUploadedChoregrapheBehaviorbehavior_11890411040rootSetLanguage_6: ALSpeechRecognition is not available, language setting cannot be applied to recognition
[ERROR] behavior.box :
init:10 _BehaviorlastUploadedChoregrapheBehaviorbehavior_11889748416rootSpeechReco_5: ALProxy::ALProxy
Can't find service: ALSpeechRecognition
[WARN ] behavior.box :onLoad:15 _Behavior
lastUploadedChoregrapheBehaviorbehavior_11889748416rootSetLanguage_6: ALSpeechRecognition is not available, language setting cannot be applied to recognition
[ERROR] behavior.box :
init:10 _BehaviorlastUploadedChoregrapheBehaviorbehavior_11893261560rootSpeechReco_5: ALProxy::ALProxy
Can't find service: ALSpeechRecognition
[WARN ] behavior.box :onLoad:15 _Behavior
lastUploadedChoregrapheBehaviorbehavior_11893261560root_SetLanguage_6: ALSpeechRecognition is not available, language setting cannot be applied to recognition

0
Avatar
Sada Nishio

qazwsxさん

返信が遅くなりました。
WindowsのバーチャルロボットではSSLモジュールが有効になっていない場合があるようです。
http://qiita.com/yacchin1205/items/3422b5066dcbfca63def
このあたりに原因がありそうな気がしますね。

可能であればPepperの実機もしくはMacで同様の操作を行ってみるとよいかもしれません。

0
Avatar
qazwsx

Sada Nishioさん
回答いただきありがとうございます。
SSLモジュールが有効になっていない件、承知しました。
Pepper実機 or MAC環境を用意して試してみます。
またwindows環境でSSLを有効にできないか、アルデバラン社のコミュニティサイトの方に問い合わせしてみます。

0
ログインしてコメントを残してください。